• Announcements

    • GeorgiTsatsev

      Some Agents Stopped Working   10/30/17

      Dear Domotz Users,    
       
      Symptom
      Please be aware that we are currently experiencing a problem on some Domotz Agents that marks them offline and makes them unreachable. This is primarily affecting the users outside of the US/North American countries.  Domotz is actively working on the resolution of this issue to minimize the impact to you and your customers.
       
      Agents Affected
      QNAP
      Synology
      Raspberry Pi
      Virtual Machine - Debian
      Domotz Boxes   Agents that were affected were running older versions of the Domotz Package (older than 2.1.4).   Agents that had the latest package should not be affected by this issue (2.1.4 or higher).   Root Cause
      Domotz is constantly updating the agent software to improve features and ensure device and network security.   In this instance, Domotz was doing a routine agent upgrade and Agents that had older versions of the package running on the hardware ended up in an offline state.  
       
       
      Resolution
      Domotz is actively working to bring back Domotz Boxes.  We have been able to recover a majority of the Domotz Boxes that had this issue through the Provisioning channel (a parallell channel to the software, mainly used for maintenance and provisioning).   For QNAP, Synology, Raspberry Pi and VM installations, it may be necessary for you to reinstall the latest Domotz software.  
      You can find instructions for updating to the latest version for the Raspberry Pi and VM version might be found on the Domotz Portal (https://portal.domotz.com --> Domotz Software --> Install Instruction for Raspberry Pi and Debian).   The new package (2.1.4) has been published on the QNAP store (available for x86-64 models and ARM x41 models (x31+, x31P, x31P2, x31X, X35) with QTS 4.3.0 and above), and on the Synology store.   We sincerely apologize for any inconvenience caused by this outage. We appreciate the fact that this affects your operations and will do our best to minimize the impact.    Regards,
      The Domotz Support Team
Tyler

wake WOL While Online

8 posts in this topic

So WOL for Mac computers is basically broken (thanks Apple)

The Bonjour features seem to keep the network cards alive and replying to pings even while the OS is sleeping (Remote Desktop unavail, etc)

The issue with this is that Domotz is constantly getting ping heartbeats so it believes the Macs are still online, thus WOL feature of Domotz is unavail.

 

I would like to ask that WOL feature be available all the time, not just when Domotz believes that a device is offline. This would solve this issue, and save me time from SShing into Raspbian to send a wakeonlan

0

Share this post


Link to post
Share on other sites

I thought about that but one of the first things I do on new machines is turn off a lot of crap, power nap included. This is a faux server so no need for it. I'll have to double check tomorrow, thanks

0

Share this post


Link to post
Share on other sites

Still having issues with this. Even with Power Nap off, a sleeping mac pro does not appear 'offline' to Domotz, So WOL is not available. I request that the WOL option be available, no matter what Domotz thinks is the device state

0

Share this post


Link to post
Share on other sites

Hi Tyler,

 

why do you need  WOL for your Mac? This Bonjour service is a wonderful thing ( if it works)

you can easy access your Mac because it shows online to all other diveses. And the Mac wake up automatically if you access.

 

but I think there is a way do disable WOD (wake on demand) in preferences.plist but I don't recommend this.

 

Edit

but I think there is a way do disable WOD (wake on demand) in Energy Saver preferences ( Wake for network access). So Wake on Lan should work.

 

More info

https://support.apple.com/en-us/HT201960

 

 

But I think you are right. Send WOL should work, even the device looks online.

0

Share this post


Link to post
Share on other sites

So while Mac is 'sleeping', it appears online to Domotz, but offline to all of my remote acess (desktop, file access, etc) which means I can't access it. I don't have any other bonjour devices on the network so using sleep proxy is out

0

Share this post


Link to post
Share on other sites

Hi

 

Can I add to this discussion please?

 

I don't believe this is just a Mac issue. I have an Intel NUC PC running Windows 10, which when I put it in sleep mode still looks online to Domotz - and therefore I can't wake it because the WOL button is greyed out.

 

I have done some investigation.

 

When the PC is in sleep, it does not return IP pings, but Domotz thinks it is still online. I presume that Domotz is doing a heartbeat check of the card at the MAC address level, and sleeping PC (and Mac) is passing this check.

 

It seems there are three device states - powered off (you can't wake it), sleeping (you can wake it) and online. And Domotz can't identify the sleeping state for (new) PC and Mac?

 

Would it be possible to modify the heartbeat check for PCs and Macs so they appear offline when they are sleeping?

 

Thanks

0

Share this post


Link to post
Share on other sites

To come back to this discussion, from my perspective my issue has gone away. So when my PC is sleeping, Domotz treats it as offline and the "Wake Up Now" button makes it wake up (as expected). I guess something was changed in Domotz.

 

Thanks

 

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now