Jump to content
Sign in to follow this  
System_Error_Message

raspberry pi 2 agent, high memory usage

Recommended Posts

System_Error_Message

When i run htop it shows 6 domotz processes using 12% of memory/ram each and ram usage is almost full. I have tried restarting the agent or even the raspberry pi but the problem still persists. Processing wise it doesnt really use any CPU.

Share this post


Link to post
Share on other sites
Giancarlo
3 hours ago, System_Error_Message said:

12% of memory/ram 

 

How much RAM does it mount? With 1 GB Ram, it is really strange the behavior you observe (memory per few processes should be less than 6-8% each).

 

A couple of processes within the Domotz Agent are quite eager in memory (around 100 MB each), but no more then a couple of them.

When looking at the top, can you post the RES memory allocated and which processes are there?

Share this post


Link to post
Share on other sites
System_Error_Message

There are 6 domotz processes using 107MB each, i dont know why but there seem to be multiple processes of everything

 PID USER      PRI  NI  VIRT   RES   SHR S CPU% MEM%   TIME+  Command

22687 root       20   0  156M  108M  9560 S  0.0 12.5  1h56:54 /opt/domotz/bin/domotz_node /opt/domotz/bin/dom
22688 root       20   0  156M  108M  9560 S  0.0 12.5  5:57.44 /opt/domotz/bin/domotz_node /opt/domotz/bin/dom
22719 root       20   0  156M  108M  9560 S  0.0 12.5  0:24.03 /opt/domotz/bin/domotz_node /opt/domotz/bin/dom
22720 root       20   0  156M  108M  9560 S  0.0 12.5  0:24.08 /opt/domotz/bin/domotz_node /opt/domotz/bin/dom
22721 root       20   0  156M  108M  9560 S  0.0 12.5  0:24.07 /opt/domotz/bin/domotz_node /opt/domotz/bin/dom
22722 root       20   0  156M  108M  9560 S  0.0 12.5  0:24.15 /opt/domotz/bin/domotz_node /opt/domotz/bin/dom

 

the raspberry pi 2 has 1GB of ram

Edited by System_Error_Message

Share this post


Link to post
Share on other sites
Giancarlo

This is quite strange. It shouldn't be like that: old version of Agent  

 

Did you try restarting the Domotz Agent?

 

Eventually, can you get the entire command from the ps?

Share this post


Link to post
Share on other sites
System_Error_Message

i tried restarting the agent already or even the pi and it didnt solve the problem. I can try updating.if theres a new version.

 

Its strange that domotz would need so much ram.

Share this post


Link to post
Share on other sites
Giancarlo
2 hours ago, System_Error_Message said:

Its strange that domotz would need so much ram.

 

This is something which make me think also. It's a strange case. We have Domotz Agents monitoring networks with 50-60 devices installed on Raspberry Pi 1, using less than 140 MB.

 

Let's see if upgrading the agent solves the issue. Alternatively we will look into your case closely.

Share this post


Link to post
Share on other sites
System_Error_Message

Ive reinstalled the agent but its saying i need a new license. I wasnt sure if the package manager automatically updated it.

Edited by System_Error_Message

Share this post


Link to post
Share on other sites
Giancarlo

You probably installed the agent, using a different network interface. At the moment there is a check on the MAC address.

 

Share this post


Link to post
Share on other sites
System_Error_Message

When you say mac address do you mean of the agent or the computer accessing the pi over ssh? Both interfaces of my raspberry pi have the same mac address.

 

I compared the license mac address to my raspberry pi and they're the same.

Edited by System_Error_Message

Share this post


Link to post
Share on other sites
System_Error_Message

The mac address is the same but it is still giving me the same error.

 

It still says no available license on this account.

Edited by System_Error_Message

Share this post


Link to post
Share on other sites
Giancarlo

We can't publish the MAC address here (privacy issue). Talking offline. Can you send me the list of MAC addresses of your Raspberry Pi?

 

ifconfig should be fine. Or "ip addr" even better.

Share this post


Link to post
Share on other sites
System_Error_Message

how do i send you the list? Theres only 1 MAC address unless it is trying to use loopback.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...