Jump to content
cfool

RPi agent going offline

Recommended Posts

cfool

Hi.  I have had a couple of times when the agent hasn't been reachable from the web-portal.  It shows as offline in the iOS app and portal.  The Pi itself is still alive in this instance, but a reboot is required to bring the agent back online.   (Perhaps there's a console command that would do the same?).

 

Where should I look for logs to troubleshoot why this is happening?

 

Thanks

Share this post


Link to post
Share on other sites
Silvio

Thanks for signalling this. Actually we have already noticed and working at fixing it. In particular we are working at two things: 1. prevent the agent from offline. 2 if this still happen, for any future reason or misbehavior, be able to make the agent auto-restarting.

The fix will be available in next version, that will be published in 2 weeks max (together with few new features)...

 

Share this post


Link to post
Share on other sites
cfool

Hi.  I am still regularly seeing this problem.  I am currently on Pi agent version 1.0.6-236.

 

I now have the Pi plugged into a Z-wave module and I test the connectivity with a HTTP Header test using a Plug-In on my home automation application, HomeSeer.  When the header test fails 3 times it powers off the Z-wave switch, waits 60 seconds and turns it back on.  It then sends me a Pushover message confirming that the agent is now reachable again.  The Pi itself is usually reachable via ping when the agent is in this hung state.

 

So, I have a working solution, but it's kind of backwards to have my HomeSeer application monitor the Domotz agent...

I am finding the agent very useful though

Share this post


Link to post
Share on other sites
Giancarlo

Hi Cfool,

 

this is an interesting case.

 

Can you please share the following information:

- Version of Raspberry Pi

- OS on that Raspberry Pi

 

Please note that if the network to monitor is quite big, and the Domotz Agent is running on a busy device (or for example on a Raspberry Pi 1), it might happen that the Domotz Agent is not able to cope with all the activities required, and in this case it becomes un-responsive.

 

In order to make the configuration of the Domotz Agent lighter, you can follow the instruction provided on this topic:

 

Let me know if that makes the Domotz Agent running smoother.

  

Share this post


Link to post
Share on other sites
cfool

Giancarlo

I am using an RPi 2 and it's running Raspbian installed directly off the noobs card that I bought at the same time.  I have about 75 known devices of which about 35-40 are usually online at a given time.   

I will try the steps in the other post to see if that helps.    

 

I also frequently have remote access attempts (RDP etc) fail upon request, which I guess could be a similar resource problem.  However, this Pi is running nothing else, only Raspbian and the Domotz Agent.

I will advise if the other steps help

Thanks   cfool

Share this post


Link to post
Share on other sites
cfool
On 4/19/2016 at 1:41 PM, cfool said:

Giancarlo

I am using an RPi 2 and it's running Raspbian installed directly off the noobs card that I bought at the same time.  I have about 75 known devices of which about 35-40 are usually online at a given time.   

I will try the steps in the other post to see if that helps.    

 

I also frequently have remote access attempts (RDP etc) fail upon request, which I guess could be a similar resource problem.  However, this Pi is running nothing else, only Raspbian and the Domotz Agent.

I will advise if the other steps help

Thanks   cfool

 

I went through the tweaks in the other post on Tuesday last week.  Wednesday was stable but I saw the agent process(es) hang 4 times over Thurs / Fri / Sat.  My automated restart process kicked in each time, but in the long term I can't imagine it's good for the SD card and OS to get powered off instantly.  At some time there's going to be corruption there.

Share this post


Link to post
Share on other sites
Giancarlo

Which is the frequency of check you perform on the Domotz Agent in order to restart it?

 

 

Share this post


Link to post
Share on other sites
Rudicircle

We're experiencing a similar issue with a group of 4 agents running on RasPi 2 Model B+ - they go offline in 2 to 5 minute periods.

 

Previously there was a fix to restrict the use of resources that I performed on one agent, but following an update it reverted back to going offline every few minutes.

 

All of the ones with said problem are running version 1.0.7-242 I believe.

Share this post


Link to post
Share on other sites
Silvio

Sorry to see this. Is the agent installed on a Domotz PI provided by us, or there is something else running on those raspberry's?

In another thread I saw that you are testing with odroid. Is that oneworking fine?

I have a feeling it might be related to something else installed on those raspberry PI or not a vanilla raspbian installed.... Please let me know (you can write me privately) Thanks.

 

Share this post


Link to post
Share on other sites
Rudicircle

Hi Silvio,

On ODroid, yes the agent is running fine without fault so far.

 

The RasPi's are not ones provided by yourselves, they are from RS-Online with the Raspbian NOOBs installation available from raspberrypi.org.

 

I have a feeling the NOOBs version has a few extra things (comes pre-loaded with user friendly software) we probably don't need and I may well try the version from raspbian.org instead.

 

I'll do a little more testing (although I think going forward we'll be using ODroids) and report my findings.

Share this post


Link to post
Share on other sites
Giancarlo

Hi Rudy,

 

we have other users experiencing issues with NOOBS.

 

Please, install just the Raspbian, available under official Raspberry download:

https://www.raspberrypi.org/downloads/

 

Let me know if you experience further issue with vanilla Raspbian.

Share this post


Link to post
Share on other sites
Rudicircle

Thanks!

That's what I'm trying now - although I've not got any licences left to activate agents on at the moment.

Share this post


Link to post
Share on other sites
Rudicircle

Update:

 

With a fresh install of Raspbian (Lite, no desktop environment) I'm still experience the agent dropping offline - it was fine for the first 10 minutes or so, then it drops off in 2-3 minute cycles.

 

What I'll try as well is the built-in overclock options (this seemed to help in previous testing)

Share this post


Link to post
Share on other sites
Rudicircle

In the linked thread there were some suggestions for how to reduce the resource consumption by the agent, I've just applied them again to see if it has any effect..

 

To save you reading through, here are the commands:

/etc/init.d/domotz stop

sed -e "s/\"nmap_max_processes\": 10,/\"nmap_max_processes\": 1,/g" -i /opt/domotz/etc/domotz.json
 
sed -e "s/StartPollers=10/StartPollers=1/g" -e "s/# StartTrappers=5/StartTrappers=1/g" -e "s/StartPingers=10/StartPingers=0/g" -e "s/# StartHTTPPollers=1/StartHTTPPollers=0/g" -e "s/# StartDBSyncers=4/StartDBSyncers=1/g" -i /opt/domotz/etc/zabbix_proxy.conf

sed -e "s/# StartAgents=3/StartAgents=1/g" -i /opt/domotz/etc/zabbix_agentd.conf

/etc/init.d/domotz start

reboot

I've applied these along with overclocking to 900 MHz for good measure.

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...