Jump to content
skd

Change Digital Logger Password

Recommended Posts

skd

Good Morning,

 

I'm trying to connect to a Digital Logger Web Power Switch.  I've changed the password  on the WPS from the default of 1234.  I'm currently getting an authentication failure when I try to manage the device through Domotz and can't seem to find any place to modify the password.  I'm currently using Domotz v1.0.5.

 

Here is some relevant log information from domotz_listener.log:

 

2016-02-26T08:15:56.5656Z [VERBOSE] Send PUT request to agent endpoint. URL: https://api-eu-west-1-cell-1.domotz.com/agent-api/v1/agent/52410/device-status?macro_category=power_plug. Special Options: undefined
2016-02-26T08:15:56.5656Z [INFO] Zabbix request handled properly. Action: device_status_update
2016-02-26T08:15:56.5656Z [INFO] Received action: listener_status_check
2016-02-26T08:15:56.5656Z [INFO] Check Listener Status. TODO: Diagnostic Module
2016-02-26T08:15:56.5656Z [INFO] Zabbix request handled properly. Action: listener_status_check
2016-02-26T08:15:57.5757Z [VERBOSE] Engine request OK! Requested URL: <https://api-eu-west-1-cell-1.domotz.com/agent-api/v1/agent/52410/device-status?macro_category=power_plug> Method: PUT - Status Code: 202
2016-02-26T08:15:57.5757Z [INFO] Message received 29e5c94a-e5bf-49cf-8e60-f03c9a14ca39
2016-02-26T08:15:58.5858Z [VERBOSE] {"command": "HTTP_REQUEST", "payload": {"basic_auth": {"password": "1234", "user": "admin"}, "path": "/index.htm", "host": "192.168.1.254", "method": "GET", "port": 80}}
2016-02-26T08:15:58.5858Z [INFO] Executing command: 29e5c94a-e5bf-49cf-8e60-f03c9a14ca39 - httpRequest - GET - http://admin:1234@192.168.1.254:80/index.htm
2016-02-26T08:15:58.5858Z [INFO] 29e5c94a-e5bf-49cf-8e60-f03c9a14ca39 - Sending request: http://admin:1234@192.168.1.254:80/index.htm
2016-02-26T08:15:58.5858Z [INFO] 29e5c94a-e5bf-49cf-8e60-f03c9a14ca39 - Got response - code: 403
2016-02-26T08:15:58.5858Z [INFO] Sending reply to message 29e5c94a-e5bf-49cf-8e60-f03c9a14ca39 on queue amq.gen-jFuvQehSIh5ftKVNojtjzQ - size in bytes: 794
 

Thanks.

 

 

Share this post


Link to post
Share on other sites
Silvio

Hi skd,

I am sorry, at the moment we only support default user and password. We haven't added yet the features for setting up your own.

I am targeting this to be released by the end of march.

Hope you can be patient for few more weeks.

Silvio

Share this post


Link to post
Share on other sites
forJO

Wondering if we still need to use the default password with Digital Loggers or if our own passwords are now allowed.  I already had a non-default password when I installed the RPi and after not being able to login to the DL WPS through Domotz I tried to change the password directly and when I went to the device directly it was in a "Security Lockout In Place" because of too many bad attempts.  I tried another WPS on my network that I never tried to connect to with Domotz and it showed the same situation so both of them are currently locked out.  Does the Domotz try to login with default password multiple times causing this?  Hopefully after some time this lockout will clear and I can try with the default 1234.

Share this post


Link to post
Share on other sites
Giancarlo

Hi forJO,

 

Domotz is now able to use a non-default password for PDUs. Please, make sure you are using latest version of Domotz Agent (1.0.8).

 

As soon as you start Domotz it tries to access to the PDU with the Default password only one time. If the PDU has not the default credentials, you will get the following in the device list:

 

Screen Shot 2016-05-15 at 7.24.58 AM.png

 

And this is how it appears within the device details:

Screen Shot 2016-05-15 at 7.25.11 AM.pngScreen Shot 2016-05-15 at 7.25.22 AM.png

 

Which means that the Digital Logger is not accessible with the default credentials. The Domotz stops trying with that credentials at this point, until you manually configure the right credentials within Domotz:

 

Screen Shot 2016-05-15 at 7.25.30 AM.png

 

 

 

Share this post


Link to post
Share on other sites
forJO

Thanks for the quick response.  I am running 1.0.8 and see the login/unlock options you show above but the Digital Loggers are still showing locked.  They are supposed to clear the lock after a max of 60 minutes but they are still locked.  Not sure if the Domotz Rpi continually pinging the device is causing this.  Any ideas on this issue.  Never had any trouble logging in before.

Share this post


Link to post
Share on other sites
forJO

I disconnected power to the Rpi and after a bit I was able to log into the Digital Loggers.  Plugged the Rpi back in and after a couple of tries I was able to login to the Digital Loggers through the Domotz connection.  So it is working now, but not sure why the lockout wouldn't go away.

Share this post


Link to post
Share on other sites
Giancarlo

Thanks for reporting this. We will do further investigation.

In the past, the Domotz Agent was performing multiple tests on the Digital Logger, causing the lock of it. But this is not the case anymore.

 

Let us know if you experience any other issue.

Share this post


Link to post
Share on other sites
Audioadam

I am trying to connect to a newer Digital Loggers web powered switch.  I too changed the default password on the unit, when I use the webconnect it does take me to the login page of the Digital Loggers and I am able to log in with my new credentials no problem, but when I try to unlock the unit with the same credentials, it fails every time.  I even removed the device, and tried again 8 hours later, after the domotz had found it (as generic), and then subsequently identified it as a web controlled switch...

 

How should I proceed to get it working?

 

Adam

Share this post


Link to post
Share on other sites
GeorgiTsatsev

Hi Adam,

 

With their latest firmware they have a new REST API that needs to be enabled in order for our software to communicate (and authenticate) with the device properly.

 

So you will need to go to the device web configuration and enable the Rest API checkbox.

Additionally on some devices you may need to enable another checkbox "Allow legacy plaintext login methods".

 

Georgi

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...