Jump to content
Tonka

on dual LAN Synology, choose which LAN

Recommended Posts

Tonka

Hello

 

Im interested in testing this for my team.

We have a Synology NAS with 2 NICs, one reaches our office network, which we dont want to monitor at this moment. The other NIC reaches a larger network, that contains equipment i wanted to test on.

 

How can i tell it to scan the other network.  I shows my office LAN.

thanks

Share this post


Link to post
Share on other sites
Tonka

 

Bumping , maybe I did not explain myself correctly. 

 

My my synology agent scanned the wrong NIC. 

How can I tell it to scan the other nic, or to treat them as different networks?

 

does support from domotz reply here? 

Im a MSP, support is important to me. 

Thanks. Nice idea. 

 

Share this post


Link to post
Share on other sites
Giancarlo

Thanks Tonka for the appreciation, and apologize for the delay in getting back to you.

 

With regard to the issue, as far as I can see from the logs, now the Agent appears to be reset, therefore we can't investigate further.

 

In general the Domotz Agent should scan both the network related to the two NICs, as far as the devices on both the network are discoverable from the Synology.

 

May I ask you if the Synology is sitting on both the LANs in the same way? For example, it might happen that one of the network you see is physically there (Network L2), and the other one is just a virtual one (e.g. a VPN - L3). In this case, the Domotz Agent only monitor the physical one, given that the key to uniquely identify the IP device, is its MAC address, which is only available for L2 network discovery. 

 

In any case, for this kind of scenario, we strongly recommend to use a dedicated device to host the Domotz Agent. Have a look at the following page for additional information about the Domotz Hardware that we offer:

 

https://www.domotz.com/installation/#domotzhardware

 

If you want to monitor a specific Network, you just need to be sure that the Domotz Agent is sitting on the same network that you want to monitor (L2).

 

Share this post


Link to post
Share on other sites
Tonka

 

The NAS has two physical network ports, one to each lan.

 

I removed the agent, let me re install again and see what it does after i tweak the network settings on the NAS

I´ll let you know.

thanks

 

Share this post


Link to post
Share on other sites
Giancarlo

As stated above, the eth1 appears to be a virtual network (VPN L3?). This can't be achieved through Domotz, given that the primary key for the identification of a device is it's MAC address.

 

In order to scan that network, you need to be sure to have a device physically connected to that Network. You can evaluate to have a dedicated device (e.g. a Raspberry Pi or a Domotz Box) only connected to that Network.

 

Alternatively you should configure the two networks as VLANs.

 

Moreover, please note that the two networks (eth0 and eth1) are clashing on the same IPs (192.168.0.x) which may cause issues not only to the Domotz, but also (and especially) to your networks.

Share this post


Link to post
Share on other sites
Tonka

 

Hello thanks for the reply 

as stated this synology nas has two physical network ports, which connect physically , to two different physical networks. 

 

The networks are not clashing. They are the same type. The network on eth0 is a small test and administration network, where we pre configure and test equipment, that is later going into the larger network connected physically on eth1.

 

the nas is the only device that touches both networks physically , and we use it to keep backups and a sys log .

it is not a common sight I agree but there is nothing really special about it. ( the nas works just fine from both sides)

 

We  have a raspberry Pi on the network, that runs another monitoring package, but we could not fit yours in there. I might test it later if I have the time. 

 

Thanks. 

 

Share this post


Link to post
Share on other sites
Tonka

 

Hello again

 

So un installed the synology client, and reset the agent on the dashboard.

Went and bought a raspberry pi, installed the OS, upgraded, installed your agent.

 

and i get this

http://screencast.com/t/cBwHS8no

 

But my account shows  Waiting for activation

 

any ideas?

I just cant get this thing working right LOL.

Share this post


Link to post
Share on other sites
Giancarlo

At the moment the Reset functionality does not release the license from the physical device (we are working to release it).

 

Therefore, that license is still bound to the NAS.

 

In order to allow you to test Domotz on the Raspberry Pi (please make sure it's a Pi 2 with Raspbian - no NOOBS), I've added a new license to your account. You should be able to configure the Domotz Agent on that, now.    

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...