Jump to content
FastTech

Cannot Remote Desktop to Windows PC

Recommended Posts

FastTech

My company is currently on the trial for the domotz software. We have installed the system on a rasberry pi. We are trying to connect to our computers in the office via remote desktop connection but we keep getting this error:

                   The connection has been closed because the server is taking too long to respond. This is usually caused by network problems, such as a spotty wireless signal, or slow network speeds. Please check your network connection and try again or contact your system administrator. 

 

Do you guys have any idea why this would be popping up?

I have allowed RDP connections on the PC.

 

Share this post


Link to post
Share on other sites
jessetn

Which version of Windows are you running?

 

If it's Windows 10 or Server 2016, you might have to turn off NLA (see attached. UNchecked).  May be the same for Windows 8/8.1 and Server 2012/R2.

Capture.PNG

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×