Jump to content

Domotz no longer running on my QNAP


KRC1

Recommended Posts

My Domotz agent on my Qnap Nas has stopped running, after stopping and removing it, its no longer able for download on the Qnap App center.

I downloaded the Qpkg file from the community admin, but that too didn't work.

Any suggestions.     

I have a TS-251.

Link to post
Share on other sites

Hi KRC1,

 

unfortunately QNAP has not yet completed the tests to promote the packages on the Market. However, we have submitted the following one, which should work for your architecture:

 

https://s3-eu-west-1.amazonaws.com/domotz-temporary/domotz-qnap-x64-4.2.0-2.1.4-0310.qpkg

 

Thanks,

Giancarlo

Edited by Giancarlo
Edit for the wrong link reported
Link to post
Share on other sites
Buzzatronic
On 11/2/2017 at 6:02 AM, Giancarlo said:

Hi KRC1,

 

unfortunately QNAP has not yet completed the tests to promote the packages on the Market. However, we have submitted the following one, which should work for your architecture:

 

https://s3-eu-west-1.amazonaws.com/domotz-temporary/domotz-qnap-x64-4.3.0-2.1.4-0301.qpkg 

 

Thanks,

Giancarlo

This file is not accessible.

 

<Error>
<Code>AccessDenied</Code>
<Message>Access Denied</Message>
<RequestId>B523B26A99C2D799</RequestId>
<HostId>
Sn0uqPDtvM6vvQYcDkmYpq3Dj+4CTZg0QiD8EX/C/eEYYivQH3a8wbhlRJmYHziUJBQZfHJ8FFI=
</HostId>
</Error>
Link to post
Share on other sites
  • 3 weeks later...
Marco_Pfiffer

Hi Guys,

I have the same problem with my QNAP NAS. The client wasn´t running anymore. After I removed the App from the NAS it is not possible to install it again. The progress comes up to 80% and there it stays for hours and days. Neither the link from Georgi nor the App install via the QNAP App center works.

Regards,

Marco

 

Link to post
Share on other sites
henriquesalvador

Hi Marco,

 

sorry about that, could you please send to us an email (support@domotz.com) with:

 

- Exact model of the NAS
- OS version of the QNAP system

 

As pointed by Giancarlo, QNAP has published back the Domotz Agent on their App Center. We are still working on the version for the Marvell architecture, which should be available soon.

 

Please send us the email with the information, we will assist you.

 

Henrique Salvador

Domotz Support Team

Link to post
Share on other sites
Marco_Pfiffer
On 28.11.2017 at 6:58 PM, henriquesalvador said:

Hi Marco,

 

sorry about that, could you please send to us an email (support@domotz.com) with:

 

- Exact model of the NAS
- OS version of the QNAP system

 

As pointed by Giancarlo, QNAP has published back the Domotz Agent on their App Center. We are still working on the version for the Marvell architecture, which should be available soon.

 

Please send us the email with the information, we will assist you.

 

Henrique Salvador

Domotz Support Team

Hi Henrique,

 

I have sent the mail with information you asked for. Looking forward to your answer.

 

Best regards,

Marco 

Link to post
Share on other sites
  • 3 weeks later...

Hi there just joined this community.

 

Tried to install the QPKG on my NAS and it failed.  I then manually installed it via SSH console and it failed.

 

[/share/Public] # sh domotz-qnap-x64-4.2.0-2.1.4-0310.qpkg
Install QNAP package on TS-NAS...
./
./qinstall.sh
./package_routines
./qpkg.cfg
./md5sum
2160+1 records in
2160+1 records out
48699771 bytes (46.4MB) copied, 0.268097 seconds, 173.2MB/s
47558+1 records in
47558+1 records out
48699771 bytes (46.4MB) copied, 0.324164 seconds, 143.3MB/s
domotz 2.1.4 is already installed. Setup will now perform package upgrading.
Executing pre-install script...
Executing main-install script...
Link service start/stop script: domotz.sh
Set QPKG information in /etc/config/qpkg.conf
Executing post-install script...
/share/CACHEDEV1_DATA/.qpkg/domotz/etc/domotz.env: line 216: 10233 Segmentation fault      domotz_hello
/sbin/setcfg: /share/CACHEDEV1_DATA/.qpkg/domotz/lib/libz.so.1: no version information available (required by /usr/lib/libxml2.so.2)
/sbin/setcfg: /share/CACHEDEV1_DATA/.qpkg/domotz/lib/libz.so.1: no version information available (required by /usr/lib/libxml2.so.2)
/sbin/getcfg: /share/CACHEDEV1_DATA/.qpkg/domotz/lib/libz.so.1: no version information available (required by /usr/lib/libxml2.so.2)
/sbin/getcfg: /share/CACHEDEV1_DATA/.qpkg/domotz/lib/libz.so.1: no version information available (required by /usr/lib/libxml2.so.2)
/sbin/getcfg: /share/CACHEDEV1_DATA/.qpkg/domotz/lib/libz.so.1: no version information available (required by /usr/lib/libxml2.so.2)
/sbin/getcfg: /share/CACHEDEV1_DATA/.qpkg/domotz/lib/libz.so.1: no version information available (required by /usr/lib/libxml2.so.2)
/sbin/getcfg: /share/CACHEDEV1_DATA/.qpkg/domotz/lib/libz.so.1: no version information available (required by /usr/lib/libxml2.so.2)
/sbin/getcfg: /share/CACHEDEV1_DATA/.qpkg/domotz/lib/libz.so.1: no version information available (required by /usr/lib/libxml2.so.2)
Starting domotz ...
/etc/domotz.env: line 145: 10332 Segmentation fault      domotz_forever --append --killSignal=${KILLSIGNAL} -p ${DOMOTZ_ROOT_DIR}/var/lib/forever -l ${FOREVER_LOG_FILE} -c ${COMMAND} start --minUptime 10000 --spinSleepTime 10000 --pidFile ${PIDFILE} ${DAEMON} >> ${LOG_FILE} 2>&1
^C
[/share/Public] #
 

 

Looks like your QPKG is incompatible with the new QTS 4.3.4.0411 firmware and my TVS-463 NAS. 

Link to post
Share on other sites
henriquesalvador

Hi @pringlee, @djatwork and @Aleborg, we really sorry about that, please send us an email to support@domotz.com and we will help you.

 

Add to the email:

  • Exact model of the NAS
  • Firmware version of the NAS system

Also, please collect the Domotz logs available on your QNAP (connecting via ssh) at the following path:

 

/var/log/domotz/

 

Thank you for your patience,

Henrique Salvador

Domotz Support

Link to post
Share on other sites
  • 6 months later...
  • 2 weeks later...

Hi @Ago

Could you give us more informations about your Qnap device? We have a qnap with X64 architecture and we didn't find issues, would be important for us to know your configuration in order to try to reproduce the problem. 

Thanks a lot for your support

 

Link to post
Share on other sites
  • 5 months later...

Hi Mauro,

i have the same problem since one year....

 

 

TS-870 Pro

Firmware: 4.3.4.0486

CPU: Core i7-3770T

Mem: 16Gigs

 

Install hangs at aprox 80% 

after canceling the install the following error apears...

 

[~] # /etc/init.d/domotz.sh start
/sbin/getcfg: /share/MD0_DATA/.qpkg/domotz/lib/libz.so.1: no version information available (required by /usr/lib/libxml2.so.2)
/sbin/getcfg: /share/MD0_DATA/.qpkg/domotz/lib/libz.so.1: no version information available (required by /usr/lib/libxml2.so.2)
/sbin/getcfg: /share/MD0_DATA/.qpkg/domotz/lib/libz.so.1: no version information available (required by /usr/lib/libxml2.so.2)
/sbin/getcfg: /share/MD0_DATA/.qpkg/domotz/lib/libz.so.1: no version information available (required by /usr/lib/libxml2.so.2)
domotz is disabled.

 

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...