Jump to content
ATCIS

Are these instructions up to date?

Recommended Posts

ATCIS

https://portal.domotz.com/portal/hardware/instructions/debian 

 

I am running Debian version 8.10 (x64) and my Domotz agent recently stopped working.  I tried to reinstall the agent using the instructions on the previously mentioned Web page.  The agent ran for a minute or two and then stopped reporting shortly thereafter.  Based on the version number, domotz-debian-x64-1.0-2.1.5-0354.deb seems really old to me.  Is there a newer one i can try?

 

Please advise, thank you. 

Share this post


Link to post
Share on other sites
Giancarlo

Sorry for the delayed answer on this. That package is still valid (it's the latest released) and the instruction on the Portal are still fine.

 

Can you please provide the issue logs you are experiencing?

Share this post


Link to post
Share on other sites
ATCIS
On 2/8/2018 at 10:10 AM, Giancarlo said:

Can you please provide the issue logs you are experiencing?

I am not sure I understand what you mean by "issue logs".  Please elaborate.

 

Thank you

Share this post


Link to post
Share on other sites
ATCIS

Here is a screen shot of the (re)installation process.  The agent seems to be running for now.  It has been running for approximately one hour.  I will leave it alone and let it run for the time being.  I plan to restart the device later tonight.  Let's see if the agent is able to recover after a reboot. . . 

 

Domotz Install.PNG

Edited by ATCIS
Cropped Screen Shot

Share this post


Link to post
Share on other sites
Giancarlo

Thanks for your feedback.

 

In your first message, you stated:

 

"The agent ran for a minute or two and then stopped reporting shortly thereafter. "

 

When I asked for error logs/traces, I am interested in the logs, effect or output that you noticed when reporting that issue. In case it happens, logs for the Domotz agents are in /var/log/domotz folder.

Share this post


Link to post
Share on other sites
ATCIS
16 hours ago, Giancarlo said:

When I asked for error logs/traces, I am interested in the logs, effect or output that you noticed when reporting that issue. In case it happens, logs for the Domotz agents are in /var/log/domotz folder.

I will note this log file location for any future issues.  I was able to reboot the device that the agent is running on two days ago, and so far it has not missed a beat. It appears that reinstalling the agent for a third time did the trick.  I will revisit this topic if the problem ever presents itself again.

 

Best wishes. . . 

Share this post


Link to post
Share on other sites
NOS4A2

@GiancarloWhat happened with ATCIS also happened with me.

After upgrading to domotz-debian-x64-1.0-2.1.5-0354.deb I wasn't able to have the agent running for more than a minute even after a couple of reboots.

However, after reinstalling it, I was able to start the agent and even after a couple of reboots the agent remains rock solid.

Not sure exactly what happened but I remember the installation script trying to delete some directory and failing. I am sure the scripts stopped (at least said it stopped) the previous agent before starting the update.

By the way, I am running the agent on a Odroid XU-4 box with Ubuntu Linux 16.04.3

Share this post


Link to post
Share on other sites
Giancarlo
11 hours ago, NOS4A2 said:

@GiancarloWhat happened with ATCIS also happened with me.

After upgrading to domotz-debian-x64-1.0-2.1.5-0354.deb I wasn't able to have the agent running for more than a minute even after a couple of reboots.

However, after reinstalling it, I was able to start the agent and even after a couple of reboots the agent remains rock solid.

Not sure exactly what happened but I remember the installation script trying to delete some directory and failing. I am sure the scripts stopped (at least said it stopped) the previous agent before starting the update.

By the way, I am running the agent on a Odroid XU-4 box with Ubuntu Linux 16.04.3

 

Thanks NOS for pointing this out.

 

If you are using the Odroid XU-4, any experience with Ubuntu Core (SNAP packaging)? If so, there is a newer version of the Domotz Package available for SNAP.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...