Jump to content

Archived

This topic is now archived and is closed to further replies.

Domenico

Support for managed network switches

Recommended Posts

Giancarlo

This is already in our roadmap: we will definitely support non-default community strings. We really take into serious consideration security, and even though we are aware that SNMP v2 (community based) is not the best in terms of security, we will allow users to use their own chosen community string. However, we are not yet sure when this will be implemented. At the moment it's just a matter of resources: we have a long list of nice and important feature to implement in the next few weeks.

Share this post


Link to post
Share on other sites
TokyoIoT

I am waiting to replace my Netgear GS108P by the GS108T :-)

Share this post


Link to post
Share on other sites
martyn62

Would love to see Pakedge network switches support! Lots of Control4 dealers using them now.

Share this post


Link to post
Share on other sites
Will-DSI

Meraki Switches, if possible.

Brocade/Foundry switches, specifically FLS648, as I have 4.

Dell Powerconnect.

Netgear GS748T.

Juniper would be nice also.

Share this post


Link to post
Share on other sites
Derek

I'm not sure if I'm missing a step here... I have a TP-Link TL-SG2424P switch. An hour ago, I enabled SNMP and set the community name to "public" with read only access. When I look at this device in my app, an SNMP tab has appeared but it says "NO SNMP DATA AVAILABLE".

 

I'm using agent 1.1.3 on a raspberry pi.

 

I just realised the firmware on the switch is the original v1.0.4 that it came with. Is that likely to be the cause of the problem or is there something else I need to do on this switch to get it working?

Share this post


Link to post
Share on other sites
ilkevinli
17 minutes ago, Derek said:

I'm not sure if I'm missing a step here... I have a TP-Link TL-SG2424P switch. An hour ago, I enabled SNMP and set the community name to "public" with read only access. When I look at this device in my app, an SNMP tab has appeared but it says "NO SNMP DATA AVAILABLE".

 

I'm using agent 1.1.3 on a raspberry pi.

 

I just realised the firmware on the switch is the original v1.0.4 that it came with. Is that likely to be the cause of the problem or is there something else I need to do on this switch to get it working?

Hi Derek,

               I have the same switch and the SNMP data is working (No POE info thogh). If I remember correctly, it took some time for the data to show up. Did you just enable SNMP ?

Share this post


Link to post
Share on other sites
Derek

I spoke too soon. Port names and traffic has just appeared so I've changed the switch to read-write and will see what happens next regarding POE features.

Just now, ilkevinli said:

Hi Derek,

               I have the same switch and the SNMP data is working (No POE info thogh). If I remember correctly, it took some time for the data to show up. Did you just enable SNMP ?

 

It took about an hour and a half to appear for the first time. Hopefully POE is on the roadmap, it would be so convenient to be able to power cycle a port from my phone when I need to.

Share this post


Link to post
Share on other sites
ilkevinli
Just now, Derek said:

I spoke too soon. Port names and traffic has just appeared so I've changed the switch to read-write and will see what happens next regarding POE features.

 

It took about an hour and a half to appear for the first time. Hopefully POE is on the roadmap, it would be so convenient to be able to power cycle a port from my phone when I need to.

I agree. I am eagerly awaiting myself.

Share this post


Link to post
Share on other sites
Derek

If there's work being done on adding support for this switch, I'm happy to help out with testing.

Share this post


Link to post
Share on other sites
Silvio

 

 

 

This thread is becoming very popular. And many of you deserve an update on what we are doing.

 

 

 

 

This is the state of the art so far:

 

 

 

- We recently started implementing automated port mapping on managed switches (together with PoE support), as an important part of Domotz

 

 

 

- Right now we have implemented support for Luxul, Cisco SG-xxx, Cisco Catalyst models

 

 

 

- The auto-mapping feature is absolutely non-trivial. I do not think there are many tools in the market able to do so (and definitely not at the price that Domotz is asking to its customers).

 

 

 

- We are doing our best in expanding support to additional brands as they each require some custom work

 

 

 

On the basis of demand thus far, our aim is to release support for representative switches of the following brands by December 2016. Not necessarily in this order:

 

 

- Netgear

 

 

- Pakedge

 

 

- Planet

 

 

- Tp-link                                

 

 

- Ubiquiti/Edgeswitch

 

 

- Ubiquiti/unifi (this is likely to come later than the others as the Unifi have a completely different implementation).

 

Any additional models/brands will be addressed in Q1 2017

 

 

Thank you for your support and feedback.

Silvio

 

Share this post


Link to post
Share on other sites
JeremyL

I'm loving the Domotz service, which I'm running on a Domotz Raspberry Pi.  I'm a newbie when it comes to managed switches, however.  I happen to use mostly Luxul networking gear, so I thought I'd enable SNMP on a Luxul XMS-1010P managed poe switch so I can see info on the switch in the Domotz app/portal.  However, I'm not sure I am configuring things correctly.  I have attached images of my Luxul XMS-1010P switch setup, which I'm guessing is wrong because the SMTP tab is not showing up on the Domotz portal for this device.  Any ideas as to what I'm doing wrong?

1.JPG

2.JPG

3.JPG

Share this post


Link to post
Share on other sites
Silvio

Sorry Luxul XMS-1010P is still not supported.

Currently supported models are: AMS-2616P, AMS-4424P, AMS-1208P.

Hope we can support 1010P  as well soon. We are in contact with Luxul for this.

 

 

Share this post


Link to post
Share on other sites
JeremyL

Actually, when I woke up this morning -- without having changed anything from the settings post I made last night -- the SNMP tab appeared on the Luxul XMS-1010P device status in Domotz. I didn't have to expose a private community with read/write access.  In fact, I created a public community with read only access on 2 Dell switches (PowerConnect 2816 and 2808), and the SNMP tab showed up in Domotoz on those devices this morning too.  I guess it takes a while for the Domotoz agent to find the SNMP info?

 

I'm going to try adding a private community with read/write access to see if that gives Domotz any additional information as it doesn't have any PoE info on the XMS-1010P yet.

 

Thanks for the help, and please keep us updated as you add more switches to the fully-supported list.

Share this post


Link to post
Share on other sites
Manfell
On 6/24/2016 at 3:01 PM, martyn62 said:

Would love to see Pakedge network switches support! Lots of Control4 dealers using them now.

 

Share this post


Link to post
Share on other sites
LFalkenburg

O.o we would like to see all those DELL, HP and ARUBA Switches fully supported (including POE). 

 

Thanks

Share this post


Link to post
Share on other sites
OPSoftware
On 16/10/2015 at 5:54 PM, ilkevinli said:

Please add support for TP-Link TL-SG2424P.

+1 for that, we use these extensively for our event management.

Share this post


Link to post
Share on other sites
Craig

In addition to Luxul, the Pakedge line of networking gear and PDU's should be included.  Also, please look into adding the Panamax M4000-PRO along with the other Panamax PDU's you currently support.

Share this post


Link to post
Share on other sites
Huub

Having a Cisco SG500XG-8F8T, I also tried the SNMP function, but for me it doesn't work. Can someone please explain what the setup in the cisco needs to be ?

I now went t Communities >> Add >> Filled in the IP address of the NAS (were DOMOTZ is installed on) and as Community string I used 'public' I tried acces mode Read Only but also Read Write, both without success. 

The SNMP menu is not appearing...

Share this post


Link to post
Share on other sites
AWHS

I don' t know much about switches. I have a couple of Netgear ProSAFE® Gigabit Web Managed (Plus) Switches (there are 8 in the series)

  • GS105Ev2 
  • GS105PE 
  • GS108Ev3 
  • GS108PEv3 
  • GS116Ev2 
  • JGS516PE 
  • JGS524Ev2 
  • JGS524PE

I have these two

  • Netgear JGS524PE
  • Netgear GS105PE

Seems like I am out of luck, they don't appear to support SNMP. No mention in the documentation

Share this post


Link to post
Share on other sites
TokyoIoT

Neither the web managed or PC application managed Netgear ProSAFE Plus switches support SMNP.

 

I am waiting for Domotz to support the GS108T which does support SNMP.

Share this post


Link to post
Share on other sites
P3R
5 hours ago, TokyoIoT said:

I am waiting for Domotz to support the GS108T which does support SNMP.

As far as I know GS108T is supported. I see mine. It's a GS108Tv2 if that makes a difference.

Share this post


Link to post
Share on other sites
IcTTH

Also add the fully managed switches from Netgear like the M4100 series.

 

Share this post


Link to post
Share on other sites
EricGosh

Thanks for the Cisco Catalyst support!
I'd love to see Cisco Meraki supported.  For those of you who haven't had the joy of a single console to manage all of your firewalls, switches, and WiFi APs... 1 click template configuration means it takes longer to unbox than it does to configure.
I wasn't able to find any SNMPv3 instructions.  Is that intentional?

Share this post


Link to post
Share on other sites
JPerel

Is there POE support for the Cisco Catalyst 3560CG-8PC switch?

Share this post


Link to post
Share on other sites

×
×
  • Create New...