Jump to content
Sign in to follow this  
System_Error_Message

Domotz agent not detecting network clients

Recommended Posts

System_Error_Message

I have domotz installed on a raspberry pi 2 that is part of 2 networks (it has 2 ip addresses). I noticed that domotz only detects the gateway which is my ISP and not my other network or any other clients. My setup is very unconventional and not something you will find at homes. Every device on my network is part of 2 networks, one for internet (my ISP gives DHCP,handles NAT and such) and 1 for internal communication.

Share this post


Link to post
Share on other sites
Giancarlo

This is quite a particular configuration.

At the moment the Domotz Agent scans one single network (C Class), which is the one related to the default gateway. Therefore, if you want the Domotz Agent scanning the clients network (the one for internal communication, you mention), you should set as default gateway on that Raspberry one gateway on your internal network. However, you should make sure that the Raspberry can go out on the internet as well, in order to communicate with Domotz backend/cloud.

Note that the possibility to allow the user to select a different subnet to scan is something we have in our roadmap. But realistically it's not something that might happen before Q1 2016. I invite you to follow this post as well, were other users also require such feature:

 

Edited by Giancarlo

Share this post


Link to post
Share on other sites
System_Error_Message

Im not doing any sort of layer 2 segmentation. It is done in layer 3. My internal network also consists of VPN clients too. My router only does layer 2 filtering to prevent leaking from my network to the other users of my ISP and also to protect against any hack attempts.

There are 2 gateways for the network however the ISP one is the default gateway because my ISP blocks NAT so it is not possible to set my router as the default gateway for internet access.

 

My asus wifi router that is only used as an access point is able to detect wired devices even though they arent communicating through it. It only shows the mac address of it though instead of the IP address since it has only 1 IP address which is part of my internal network. So wired devices connected to my switch show up on my asus wifi router since it is connected to the same switch.

Edited by System_Error_Message

Share this post


Link to post
Share on other sites
Jjason

+1 for being able to select more than just one IPv4 /24. While this is common for basic home networks, more folks are adding guest subnets, DMZ subnets, and so on. 

 

Thoughts based on experience: 

1. Use the IP subnets from the interface(s) as the default range(s).

2. Have a settings box that allows the user to add/change/delete IP subnets to their heart's content.

3. Same logic applies to IPv4 and IPv6. 

 

Hope this is useful!

Jason

  • Upvote 1

Share this post


Link to post
Share on other sites
System_Error_Message

I think the most important bit is that the agent isnt detecting any of my network clients. Even though i have 2 networks clients are part of both networks at the same time but nothing comes up on the agent, only the gateway.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...