Jump to content
Sign in to follow this  
Automate

Agent not detecting a Windows PC

Recommended Posts

Automate

Agent running on RPi is not detecting one of my Dell laptops running Win 7.  The laptop is on WiFi and does go to sleep when not in use but it's on enough that the agent should detect it.  16 devices have been detected by domotoz including 2 Win PCs.  Is there a way to force a scan of the network?   

Share this post


Link to post
Share on other sites
Lars

No, there's no way to force a scan right now. 

That said, this sounds odd, as there's no reason why the device shouldn't show up.

Share this post


Link to post
Share on other sites
Automate

Just tried, and I can't ping it from the network. I'm guessing it has the Windows firewall turned on.

Share this post


Link to post
Share on other sites
Giancarlo

Actually, even if with the firewall enabled, the Domotz Agent should be able to detect it.

The scan is triggered periodically: therefore, if the Win 7 laptop is on for few minutes, it should be detected by Domotz. Are the RPi and the Laptop on the same class C subnet?

Share this post


Link to post
Share on other sites
Automate

@Giancarlo  Yes, all devices are on the same class C subnet, both wired and wireless.

 

So my Agent has been running for 6 days and never detected this one computer.  All this time the computer was on (although during inactivity it does go to sleep) and at least 8 hours a day it was used by someone with internet access so I know it was on the network.  The user was a non-admin user.   I wanted to check how the firewall was configured so I logged in as an admin and saw the firewall was turned on but basically nothing was being blocked.  So I checked domotz and the computer just showed up for the first time ever.  I could also ping it on the network.  Strange 

 

Back to the topic of Windows firewall.  It can configured to block pings so what protocols/ports does the agent use to find devices?

Edited by Automate

Share this post


Link to post
Share on other sites
Giancarlo

The Domotz Agent is working both with ping and ARP ping to identify devices which are alive. We will try to reproduce this scenario in our test bed and check if anything else can be done in such scenario. 

Share this post


Link to post
Share on other sites
System_Error_Message

This would explain why domotz isnt detecting some of my network clients since they dont respond to pings. When using static IP they dont respond to pings but on my ISP network they have DHCP but arent being detected although they do respond when i ping them on the raspberry pi in the 10.xx network but not in the 192.xx network.

Edited by System_Error_Message

Share this post


Link to post
Share on other sites
Automate

Found the problem.  Windows Firewall was set to block all incoming traffic (including pings) but only when connected to a public network.  Due to other network changes I had made, Windows did not recognize my home network and assumed it was on a public network and thus blocked the pings.

Share this post


Link to post
Share on other sites
System_Error_Message

for me thats not an option since i use a static config so it will always say it is a public network.

Share this post


Link to post
Share on other sites
Automate
1 hour ago, System_Error_Message said:

for me thats not an option since i use a static config so it will always say it is a public network.

Then you will have to create a Windows Firewall rule to allow incoming ping requests.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...